Cannot find preprocessor for Fortran when installing Octopus 9.1 software package

by Statsar   Last Updated October 20, 2019 04:01 AM

I am trying to install Octopus 9.1 program on MacOSX by following the instructions given here https://octopus-code.org/wiki/Manual:Installation#Configuring. I have made sure I have all the required libraries installed before installing this program. I also set some recommended environment variables beforehand, using gfortran as my fortran compiler,

export FC=gfortran

export FCFLAGS="-march=athlon64 -msse2 -mfpmath=sse -malign-double -funroll-loops -O3".

The above flags are what is recommended here. Then when running the configure script I got this error: configure: error: Could not find preprocessor usable for Fortran. I look at the preprocessor page of that wiki and it says that the preprocessor is controlled by FCCPP variable and for MacOS the recommended value is clang -E -ansi. Setting this variable and running the configure script again does not get rid of the error.

Tags : configure


Related Questions


Updated May 28, 2019 09:01 AM

Updated June 22, 2019 17:01 PM

Updated July 29, 2019 13:01 PM

Updated October 21, 2017 06:01 AM

Updated April 13, 2015 20:00 PM